[bitc-dev] Current thoughts on mixfix
Jonathan S. Shapiro
shap at eros-os.org
Sat Sep 4 06:20:00 PDT 2010
On Fri, Sep 3, 2010 at 9:29 PM, wren ng thornton <wren at freegeek.org> wrote:
> In particular, it's fine to define
> the *function* _+_ by saying it's equal to add (and then
> specifying/relying on inlining to remove the indirection); but having
> _+_ belong to a separate ontological category from add is just begging
> for problems.
I tend to agree. Unfortunately there is a moderately bad problem with this:
it ties the name of the syntactic element to the name of the function.
So now, if I want to define a completely new syntax in which _+_ means
something else entirely, I get tied up in namespace issues...
I confess that I'm not very sure what to do about this, and for the moment
I'm actually implementing what you advocate.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the bitc-dev